Firefox 10 起,附加元件將一律預設為相容

我們相信每個人都有其獨特的網路習慣,也值得擁有專屬的網路體驗。雖然大家從 Firefox.com 上下載的 Firefox 都是一樣的,但隨著日子一天天過去,你或許會更換個性面板、或是調整按鈕的位置,以便讓 Firefox 符合你的使用習慣;尤有甚者,還會從數以千計的附加元件中挑選配備, 為自己家的小火狐加強實力。

不過附加元件好歸好,遇到 Firefox 版本升級時則總要折騰一番。每個套件都有其「相容」的版本號碼設定,而新版到來時雖然許多套件都能順利升級,但仍有部份久未更新的套件被系統判定為「不相容」而停用,造成大家對新版裹足不前。這問題困擾大家的程度,光用 Firefox、套件、相容三個關 鍵字問 Google便知。

這個狀況在 Firefox 調整開發節奏,進入快速循環模式後又再次被提出來討論,終於有個解決方案!從 Firefox 10 起,僅有已經被明確標示為不相容的套件,才會被自動停用;一般使用者終於不必再做任何事情,就可以沿用他捫心愛的舊套件了!不過畢竟 Firefox 升版號也不是升好玩的,有些內部的程式邏輯畢竟與舊版不同,甚至也確實會影響套件正常使用。如果你發現某個套件真的就不能用了, 該怎麼辦呢?這時請使用 Mozilla 本家出品的 Add-on Compatibility Reporter,就能輕鬆告訴套件作者:這個套件壞掉了!在蒐集一定數量的回報資訊之後,Firefox 會將這個套件明列為不相容,你也可以因此幫助其他使用者確實抓出不能用的套件。

預設相容是 Firefox 討論已久終於實現的機制,很需要各位老手多幫忙回報套件的相容資訊。如果你還沒有裝,那現在就快去下載 Add-on Compatibility Reporter 吧!

您可能也會喜歡

目前找不到相關文章

共 1 則讀者回應

  1. 參照: Firefox 版本升級之迷思 | 訊息中心 | Mozilla Taiwan

對此文章發表回應

你的電子郵件位址並不會被公開。 必要欄位標記為 *